WikiElectronique

Wiki sur l'électronique et l'informatique

Outils pour utilisateurs

Outils du site


avr_studio

AVR Studio

AVR Studio est un environnement de développement gratuit réalisé par Atmel.

Télécharger AVR Studio

Programmation en C avec AVRGCC

AVR Studio n'intègre pas de compilateur C donc avant de créer un projet installez WinAVR

Création d'un projet

Démarrez AVR Studio

:avrstudio:avrstudio_welcome.jpg

Cliquez sur “New project”
Sélectionnez “AVR GCC”
Indiquez un nom de projet (mon_projet) et un emplacement (C:\Prog_AVR_C\mon_projet\):

:avrstudio:creation_projet.jpg

Cliquez sur “Finish”

Mon 1er programme

Entrez le code suivant dans le fichier mon_projet.c :

#include <avr/io.h>
 
int main (void)
{
	DDRB = 0xFF; 	//Met le port B en sortie
	PORTB = 0x0F;	//Met les 4 bit de poids faible à 1 et les 4 bits de poids fort à 0
 
	return 1;
}

Sauvegardez le projet : File → Save
Compilez le projet : Build → Build

Vous ne devrier pas avoir d'erreur :

:avrstudio:compil.gif

Configuration

Dans Project → Configuration Options vous trouverez toutes les paramètres de compilation, microcontrôleur, fréquence, librairie etc. Si vous préférez utiliser un Makefile fait manuellement, c'est aussi possible en cachant la case “Use External Makefile” et en sélectionnant votre makefile qui doit se trouver dans le même répertoire que votre projet.

:avrstudio:config.jpg

Device: Le micro que vous utilisez
Frequency: La fréquence de fonctionnement de votre micro.

Optimisation de la compilation

Par défaut “Optimization” est sur -O0, ce qui veut dire aucune optimisation à la compilation. Il est donc préférable, avant de programmer votre micro, de le mettre sur -Os pour diminuer la taille du fichier compilé.

Simulation

Apres la compilation, cliquez sur la Debug → Select Platfrom and Device … Sélectionnez AVR Simulator et ATmega128 (C'est le microcontrôleur utilisé dans la configuration par défaut)

:avrstudio:simul.jpg

Cliquez sur Debug → Start debugging après une compilation.
Dans le fenêtre I/O View cliquer sur le “+” de I/O ATmega128, cliquez sur le “+” de PORTB.
Il existe différentes méthodes d'exécution dans le mode simulation. Cf menu Debug.
Nous allons utiliser le mode pas à pas (Step into ou la touche F11)
Appuyez une fois sur F11 pour faire avancer d'un pas les instructions C de votre programme. Allez jusqu'à la fin de votre programme de cette manière vous verrez évoluer les registres DDRB et PORTB comme indiqué dans votre programme.

Visualiser l'évolution d'une variable

Pour visualiser l'évolution d'une variable C, apres avoir démarré la simulation, cliquez sur View → Watch et entrez le nom de votre variable dans le champ Name d'une des lignes.

:avrstudio:watch.jpg

avr_studio.txt · Dernière modification: 2014/10/25 03:01 (modification externe)