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1. Prise en main

1.1 Création d’un projet

Ouvrir eagle le "Control Panel" s'affiche.
File -> New Project
Un nouveau dossier apparait renommez le.

Control Panel

File Wiew Options ‘Window Help

Mame Description Project Folder

LJ:J ler..anes Lbanes Thiz folder containg subfolders which contain all pour

#- Design Rules Design Rules projects.

- User Language Programs Uszer Language Programs

& Scripts Script Files Subfolders which contain an EAGLE project file [2agle.epf]
P R e have a_red falder icon. Click on a proiect's_mgrker h_ere in

: the projects branch to open or close an existing project.

Project Folder

< |
C:\Program Files\EAGLE-4.11\projects

[

1.2 Création d'un schéma

Cliquez sur votre répertoire de projet

File ->New Schematic

La fenétre"Schematic" s'affiche

File -> Save As et donnez lui le méme nom que le projet.

E 1 Schematic - C:\Program Files\EAGLE-4.11\projects\lelectroniquellelectronig.. . Q@
File Edit Draw Wiew Tools Lbrary Options Window Help

Q@ BE 7
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Info i® Show

Display ™ fx, Mark

Move f+ % Copy
Mirror E3 4 Rotate

Graup il 4 Change
Cut o~ ™ Pasle
Delete x Add
Name 5 5 Value
Smash 3

Pinswap 11 &3 Gateswap
Spiit 3% Invoke
Wire /T Text
Circle O D arc

Rectangle & gl Polygon
Bus il 2| Net
Junction ™ Label

ERC i)

a) Ajouter un composant

Cliquez sur l'icone" Add" & pour insérer les composants a partir des librairies.

=T ADD X

Hame |
[+ opocoUpier

# pal

[+ piher

# pinhead
[#- pld-intel

[ platech

& pat

[ pat-vitrahm
[ potsicor |

# pte-nte > N AM E >NAME

= rel

=] E—E R %UE
C-E0025-0254050 T>VA|_ UE

C-EUDZ25-030<050
C-ELI025-040:050
C-EUDN25-050<050
C-EUID25-0B0-050
C-EU025_050-025+0
C-EUN25_050-035<0
C-ELI025_080-045<0
C-EU025_050-055+0 =
C-EUIDS0-024<044 CAPACITOR, European symbol
C-ELI0B0-025-075
C-ELI050-030075 Package: C025-024x044
C-ELING0-0354075 CAPACITOR
C-ELI00-045:075
C-ELIN50-050075 grid 2.5 mm, outling 2.4 % 4.4 mm
C-EUIDS0-058<075
C-EU0S0-0754075 o
1% | ¥
Search Smds [#] Preview
[

|
)

[ Ok ] [ Drap ] [ Cancel

Validez avec OK.

Le composant apparait au bout de la souris.

Posez le sur la zone de saisie du schéma en clinquant avec le bouton gauche de la souris.
Le bouton droit permet de le faire tourner par pas de 90°
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b) Modification nom et valeur du composant

R
Le nom : Cliquez sur l'icone "Name" & et ensuite sur le composant. Modifiez le nom et validez
par OK

5]
La valeur : Cliquez sur l'icone "Value" @ et ensuite sur le composant. Modifier la valeur et
validez par OK

=

L'icone"Smach" permet de dissocier le nom et la valeur du composant pour les déplacer.

c) Déplacer un composant

L'icone"Move" & permet de déplacer un composant. I suffit de cliquer sur "Move" puis sur le
composant. Quand le composant apparait en noir et blanc vous pouvez de nouveau le faire
tourner avec le bouton droit de la souris.

A I . .
L'icone"Rotate” F permet une rotation directe du composant.

d) Les autres commandes de bases

Pour appliquer une commande, le principe et toujours le méme, il faut cliquer sur la commande
et ensuite cliquez sur 1'objet sur lequel on veut I'appliquer.
L'icone"Copy" #% permet la copie d'un objet.

" E3

L'icone"Mirror permet d'appliquer un effet miroir.

L'icone "Group" i--i permet de sélectionner plusieurs objets en vu de leur appliquer une autre
commande, avec le bouton droit de souris, qui s'appliquera a toute la sélection.

ux

L'icone"Delete supprime.

A oo . , .
L'icone"Invoke" ®**: Certain composants sont formés de plusieurs blocs, comme par exemple
une 4011 qui est composée de 4 portes NON-ET a 2 entrées et les pattes d'alimentation.

Mame (5
(=) 40kx
[+- 4000
- 4001
i 4002 NG 5 [™N\C
- 4008 3 11
- 4007 b2 2 ]
#4008 5 =VALUE SWALUE & -1
= 4009 P Ih-wme |
400D S 2N 12 PND ‘seevony
4009M B 4 11
= 4010 :D} ;&
40100 =WALUE =ALUE
4070
= 4011
40110
£ 4012
4013 Quad Z-input NAND
; 33}; Package: DIL14
#4018 Dual In Line Package
= 4017
w ANA b
< »
Search Smds Preview
ok I [ Drop ] [ Cancel
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En clinquant sur ok pour sélectionner se composant seul la porte A apparait. Pour pourvoir
insérer les autres parties dans le schéma, il suffit de cliquer sur "Invoke" puis sur le composant.

B Invoke: IC1 (4011N) X

Gate | Symbal  Add Swap | Sheet

4011 Mext 1
01 Mext 1
4011 Mext 1
PwWRN  Request 0

To o m
ocooo

| QK | I Cancel ]

Les autres parties du composant sont alors disponibles.

L'icone"GatesSwap" 8 : Si vous réalisez, en faisant le typon, qu'il serait plus facile de cabler les
connexions de la porte A sur la porte B, tout n'est pas perdu, vous pouvez utilisez Gates Swap.
Cliquez sur GatesSwap puis sur la porte A puis sur la porte B. La porte A devient alors la porte B
et inversement.

e) Connecter les composants

lere chose a faire pour ceux qui n'ont pas les yeux en face en des trous, comme moi, afficher les
points de connections.

Cliquez sur "Display" - puis sur 93 a coté de Pins pour activer la couche. Des petits cercles
verts apparaissent au bout des pattes des composants. Le but du jeu est de bien viser dedans.

Cliquez sur "Net" "= et faite les connections entres vos pins.

Pour forcer la connexion de 2 nets qui se croisent vous pouvez utilisez "Jonction" "

Pour vérifier les connections, cliquez sur "Show" “** | toutes les liaisons au méme potentiel passe
en surbrillance.

f) Nommer les nets

R
-
Cliquez sur "Name" '" puis sur le net. Pour afficher le nom sur le schéma, il faut cliquer sur

"Label" ™ puis sur le net.

/N\ Si vous donnez le méme nom a 2 nets eagle, vous demandera si vous voulez les connecter
ensemble. Si vous valider par YES la connexion sera faite, elle ne sera pas visible sur le schéma
mais sera prise en compte dans les connexions pour le typon.

H':E}'

Si vous avez un doute vérifiez avec "Show

g) La vérification
Cliquez sur "Show" O pour vérifier si tout est bien connecté et rien court-circuité :)

L"ERC" & permet la vérification finale, si toutes les pattes d'alim de composant sont bien
alimentées, si vous n'avez pas de court-circuit etc.
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1.3 Création d'un Typon

Une fois le schéma terminé.

File -> Switch to board

Une fenétre avec les composants et les connexions s'affiche. (les fils jaunes)
Sauvegardez File -> Save

Placez vos composants dans le cadre.

File Edit Draw View Tools Library Options ‘Window Help

EH&E&%F B @ E
Angle: (270 | ||

aaaa@e~ @i 7
|
i _@Winch[3503ﬂﬂ] [ )

Left-click ko select object to move

a) Tracer les pistes

Info § & Show
Display By {8 Mark

woe B ER v Cliquez sur "Route" @ pour transformer les connexions en pistes.

Mirror Ed r\ Rotate

Group [} # cChange

Cut o#~  Paste W EBctom v| | |/ ST m o4 S Miter O ~MIUF P Width: 0016

Delete X 4y Add .

Nasie R & Value B9 ¢ Ly 1-16 % | Diameter |auto %) Dril: 0.024 % _

Smash =

Pinswap {7 ¢+§ Replace A \ .

soit | 2 Opimize UNE nouvelle barre apparait, avec les paramétres des pistes.
rate 7% Rew  Face ou sera tracer la piste:

Wi T Text | gt L

o Bl 1B Batom ¥| pace soudures 1 ToP Face composants
Roctangie B ] Povoon  yidty (0,032 w0 -

Ve o - Largeur de la piste

Hole [o)

Pour effacer une piste, utilisez"Ripup"

Ratsnest | 4% S Auto
ERC &} DRC

)

Errors &

b) Via ou strap

Pour faire un via, il suffit de faire une piste sur une couche, changer de couche dans le menu et
continuer la piste.
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La taille et la forme du Via peuvent étre modifiées dans le menu.
B ©® © Lae 116 v|Diameter [awto % | Dril: [0.056 ¥

Cliquez sur "Ratsnest" P de sorte qu'eagle re calcule le raccordement des connexions les plus
courts possibles.

c) Vérification

Cliquez sur "DRC" = pour vérifier si les régles de conception sont bien respectées. Un exemple
de typon terminé:

DICl 6F8"rﬁl3 E

[IE JN‘rl 48Jp2

d) Impression

Pour activer ou désactiver les différentes couches allez dans "Display"
Dans notre exemple:
-Face soudures+pastillest+vias +cadre (Bottom +Pads+Vias+Dimension)

= Display, [E3]
apers

e
220 bPlace
23 Origins
24 bOigns v

Mew | [ Chage |[ Del |

File->Print... cochez Black OK
-Face composants+vias+cadre+pastilles(Top+Vias+Pads+Dimension)
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= .

Al [ None

File->Print... cochez Black et Mirror OK
-L'implantation+cadre (tPlace+bPlace+Dimension)

File->Print... cochez Black OK

1.4 Création de librairies

a) Composition d’une librairie

Premicrement, nous allons regarder a quoi ressemble une librairie.
Ouvrez le Control panel File->Open->Library... et choisissez 74XX-eu.lbr
Cette librairie contient 3 types d'éléments.

1. Symbols : Ce sont les symboles qui apparaissent dans le schéma. Cliquez sur L (symbol)
pour faire apparaitre la liste des symboles de cette librairie. Choisissez le 7404

b- @

2. Packages : Ce sont les boitiers ou packages qui apparaissent dans le typon. Cliquez sur &
(Package) pour faire apparaitre les boitiers de cette librairie. Choisissez le DIL14.

3. Devices : C'est la liaison entre les symboles et le boitier d'un composant. Ex: la 74LS04 est
composée de 6 portes inverseuses 7404 et de 1'alim VCC GND qui sont dans un boftier de type

DIL14. Cliquez sur 33 (Device) et choisissez 74*04.
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"1 Livrary - W regram | e ALMEE 4, 1 1MbrAT4mm e lbe §74504. devd
Pin Dl [ross e Uiy Cpbora @ieeiss ok

& R QAR =00 7
e [iVnchsom | | -
-
& I e LI -1-1-1-0-1-1-
1 'I“ '+ ---->-:--r' ;,.->—.-..-: ‘paggEe
o
# Failpg Vsl
] - P oL M o
0 i o
- e 1T o o
> ey >_—-—- [t | ot
[ r ||C
Y 5l | O

b) Création d'un symbole

Il existe deux maniéres de faire un symbole soit le faire de AaZ soit partir d’un symbole déja
réalisé, le copier et le modifier.

1) De AAZ

Allez dans le control Panel, File->New-Library et cliquez sur - . Entrez un nom a votre

symbole et validez par ok. Dessinez votre symbole.
=EIRONIRU
iEx sz [\

EN

Pour dessiner le contour utilisez I'outil et choisissez les options dans la barre qui apparait :

JELECTRONIQUE FREEFR

> NAME

A\ ALLE

Vérifiez bien que vous étes sur la couche Symbols. Insérez un ">NAME" sur la couche Names et
un ">VALUE" sur la couche Values

Insérez ensuite les pins avec l'outil —., la barre d'options apparait :

T[] [He & @ 3 F [E= = B 8| Diecton: [ ¥ Sweplevet: [0 v

Choisissez la direction, un symbole spécifique, la longueur, ou sera placé nom et le mode 1/0.
e L i o) D N\ I:I U
= == [\

Dans mon cas j'ai simplement inséré une patte IN et une OUT inversée.

JELECTRONIQUE FREEFR

~NAME

~\/ALLE
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Sauvegardez votre Chef -d’oeuvre File->Save As
2) Copie modification

11 arrive souvent qu'il existe déja un symbole qui se rapproche de ce que vous voulez, alors pour
se simplifier la vie on va I’utiliser comme base.
Allez dans le control Panel, File->Open->Library et choisissez, par exemple, la 74XX-EU.Ibr,

Lr

cliquez sur et choisissez le symbole 7400.

Vérifiez que toutes les couches sont bien visibles avec , sélectionnez la totalité du symbole

avec *--*, cliquez sur le groupement avec Of.
Maintenant que votre symbole est copié¢ dans le presse-papier, allez dans le control Panel, File-

>New->Library et cliquez sur the . Entrez un nom a votre symbole et validez par ok et pour finir

sur = . Votre symbole devrait apparaitre. Placez le au centre de la grille.

Pour faire apparaitre la couche pins allez dans -
Voila maintenant vous pouvez modifier votre symbole. N'oubliez pas de le sauvegarder la fin !

c) Création d'un boitier

Tout comme les symboles, il existe 2 méthodes la création de AaZ et la modification d'un boitier
déja existant.

1) De AAZ

Dans la fenétre ou vous avez créé le symbole, cliquez sur ﬁﬁ . Entrez un nom a votre boitier et
validez par ok.

Modifiez la grille en fonction des dimensions en cliquant sur View->Grid... Dans mon cas je
veux faire un DIL8 donc je vais passé en 0.025 inch et multiple de 2.

Commencez par placer vos pastilles en cliquant sur Pad ® ¢t comme d'habitude la barre
d'options apparait.

B9 © © ® Diameter: [auto (%] Dill 0.032 | Angle: |0 o
Vous avez la forme, le diamétre de la pastille, le diamétre de percage et 'angle.

Si vous voulez faire du CMS, pas de probléme, c'est juste a coté -
Placez votre boitier au centre de la grille.
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Ensuite dessinez votre boitier avec sur la couche tPlace, le texte sur tPlace, >NAME sur
tNames et >VALUE sur tValue.

jelectronique.free.fr

Sauvegardez le tout avec Save All et voila c'est fini !
2) Copie modification

Voir la copie et la modification d'un symbole, c'est le méme principe.

d) Création d'un composant

Cette partie permet a Eagle, lors du passage schéma typon, de savoir quels symboles, le nombre
et comment ils sont connectés dans le boitier.

oo
Dans la fenétre ot vous avez créé le symbole et le boitier cliquez sur T® . Entrez un nom a
votre composant et validez par ok.
Dans mon cas, je vais intégrer, dans mon boitier DIL8 , 3 fois le symbole que j'ai fait et les pattes
d'alim.

Cliquez sur :[k , votre symbole doit étre dans la liste, cliquez sur OK et placez le dans le cadre

de gauche.

Dans mon cas je vais en mettre 3. IIs prennent automatiquement des noms différents B§1,B$2 et
[

BS$3 ... pas génial comme nom. Pour les changer, il faut cliquer sur T et ensuite sur le

symbole. Je les ai renommées en A,B, et C. HORREUR ! Je n'ai pas mes pattes d'alim dans ma

librairie. Ce n'est pas grave !, je vais simplement les récupérer dans la librairie 74XX-EU.Ibr

sous le nom PWRN et le rajouté dans un nouveau symbole de ma librairie que je vais appeler

Alim.

Je l'insére dans mon device pour compléter la liste de symbole de mon composant.

Ensuite cliquez sur le bouton New en bas a droite et sélectionnez votre boitier. Ca doit vous

donnez un truc du genre :

" 1 Library - C:Wropram Files\EAGLE4,11\br\jelectrenique. lbr (JELECTRONIQU, .. [=)[E)]
Fhe Edt Draw Yiew Lbrary Oplions Window Help

EEHS BE> M QaaQaf ~~ o8 7
P g
= i |

- L” ;' \ Lil_r_“ém ]:ﬁ::?;nmuuz o ®

=REE NS ==

Ium @® o O On

Ear

P
R

X

2

Pour que le symbole de I'alimentation ne soit pas inséré automatiquement sur le schéma mais en
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oo
utilisant ®% i] faut mettre le paramétre Add=Next sur Request. Utilisez # puis Addlevel,

sélectionnez Request et cliquez sur le symbole de I'alimentation.

L'assignation des pins des symboles aux pads du composant se fait en cliquant sur Connect. Pour
la patte d'alimentation VCC cliquez sur Alim.VCC puis sur P$8 et pour finir sur connect.
Procédez ainsi pour toutes les pattes.

File->Save all

Pour que la librairie soit utilisable, il faut encore l'activer en allant de le control Panel et en
activant la "led" verte a coté du nom de votre librairie, dans la liste "Libraries".

Ca y est votre composant est ter mi né !

FAQ Eagle : http://jelectronique.free.fr/forums/viewtopic.php?t=44

FORUM Eagle : http://jelectronique.free.fr/forums/viewforum.php?f=13
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